Zoho Banner September 2011

I’ve had my Lenovo Ideapad Yoga 13 for a little over a year now. Generally, I’m very happy with it.  It has two internal SSDs, 8GB RAM and an Intel Core i7 processor.  Windows 8.1 runs very nicely on it.  I use the Ideapad for my day-to-day work as well as running test labs in Hyper-V.  Memory is generally my main limitation with Hyper-V, but mostly I can starve the VMs of RAM as performance isn’t a key issue for me for demos and/or testing purposes.  [As an aside, Exchange 2013 is a complete resource hog and won't run nicely unless you give each machine at least 4GB of RAM, which makes running a DAG near impossible for me].   Recently, I noticed that my disk latency (average response time) on the SSD that I run the VMs off was really high (around 11,000ms).  Ok, I was running 3 VMs simultaneously, but still!  So I downloaded AS SSD Benchmark to see how my SSD was performing.  The overall result was 438, which is not great when compared with what others have posted on line with the same SSD.

as-ssd-bench M4-CT256M4SSD3 15.07.2014 8-31-44 a.m.

After some deep thinking (i.e. staring idly into space over a coffee), the idea struck me that Bitlocker might be the culprit.  So I disabled Bitlocker for that drive and tried again. The difference was significant (around 20%) without being remarkable.  Interestingly, the read times before and after were almost identical.  The write times were where the difference was appreciable.

as-ssd-bench M4-CT256M4SSD3 15.07.2014 4-29-01 p.m.

The disk is still performing slowly compared with others online.  I checked my other SSD (a Samsung) and it was also slow, so the conclusion I’ve reached is that there must be some other factor (controller?) causing the slowness.  It would be interesting to hear what others with Ideapads are seeing, or if you have any ideas on how to improve performance.  Windows 8.1 is apparently optimised for SSD use, so I haven’t found any silver bullet for speeding things up.

3 Comments

  1. Mike Crowley says:

    I’m using a Dell E6520 with a Samsung 840 Pro SSD. 8GB RAM. I’ve got BitLocker and Hyper-V in use, and haven’t noticed any real lag. I fired up my guest 2012r2 VM which runs AD and Exchange 2013. I also have Outlook and Lync open in the host Win8.1 VM. While the VM was booting (presumably heavy load) I get these results: https://mikecrowley.files.wordpress.com/2014/07/ssd-test-1.png

  2. Mike Crowley says:

    I stopped Outlook, Lync & Defender and shut down the Guest VM. Bitlocker still enabled. Here are the new results: https://mikecrowley.files.wordpress.com/2014/07/ssd-test-2.png

  3. Christian Schindler says:

    I get nearly the same results (one excemption: Acc.time writing is 0.178 – far better) – and I also own a Yoga 13(although I only have one SSD). I also think it’s a controller/driver issue… Christian

Leave a Reply